Our engineers appear to have resolved the issue with Banner Self-Service without the web application security vendor's assistance. Banner Self-Service should now be available to all users off-campus without VPN. Please report any problems accessing Banner Self-Service, regardless of location, to ti@davidson.edu.
Posted Sep 10, 2023 - 21:04 EDT
Update
Banner Self-Service remains unavailable off-campus after the conclusion of the maintenance window due to an issue with our web application security vendor. We are waiting on their support team to identify the issue with their platform and provide a resolution. For now, anyone needing to access Banner Self-Service may do so by first connecting to VPN.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2023 - 08:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 06, 2023 - 07:26 EDT
Scheduled
Banner Self-Service (bannerweb.davidson.edu) and Banner Admin Pages will be unavailable from Saturday, September 9 at 9am until Monday, September 11 at 8am. This disruption in service is in support of a significant upgrade.
Posted Sep 06, 2023 - 07:26 EDT
This scheduled maintenance affected: Enterprise Applications (Banner).