Etrieve documents loading slowly
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Sep 27, 2023 - 08:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2023 - 09:22 EDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2023 - 14:03 EDT
Investigating
Starting Monday afternoon, Etrieve documents have been loading very slowly (document.davidson.edu). We are working with the vendor to resolve this.
Posted Sep 19, 2023 - 08:03 EDT
This incident affected: Enterprise Applications (Etrieve).