Echo 360 Outage
Incident Report for Davidson College
Resolved
The Echo 360 nationwide outage has been resolved. For details on outage cause, visit status.echo360.com for more information.
Posted 10 months ago. Sep 14, 2018 - 12:05 EDT
Investigating
Echo 360 has reported a national outage. They are investigating the issue and its cause. Please stay tuned to status.echo360.com for updates.
Posted 10 months ago. Sep 14, 2018 - 09:31 EDT
This incident affected: Teaching & Learning Platforms (Echo360).