Issues with Add/Drop
Incident Report for Davidson College
Resolved
The issues with the number of seats available for Add/Drop has been resolved.
Posted Jan 03, 2023 - 09:50 EST
Investigating
T&I has been made aware of issues with seat availability within the Add/Drop application. We are investigating the issue and will provide further updates as they become available.
Posted Jan 03, 2023 - 07:30 EST
This incident affected: Misc. (Misc.).