webapps.davidson.edu is currently down
Incident Report for Davidson College
Resolved
The webapps.davidson.edu issue has been resolved and the site is now available. If you have any questions, please contact us at ti@davidson.edu.
Posted 10 days ago. Oct 08, 2019 - 09:20 EDT
Investigating
webapps.davidson.edu is currently down. T&I is investigating the issue and will post updates as soon as they are available.
Posted 10 days ago. Oct 08, 2019 - 08:53 EDT